Supporto Bitrix24

Attenzione! Dal 30 settembre 2021 sono possibili i problemi di connessione ai siti e agli online store di Bitrix24

Dal 30 settembre 2021, ore 16:01, i clienti che utilizzano la vecchia versione del browser o del software possono riscontrare dei problemi sui propri server e hosting:

  • quando ci si connette ai siti e agli online store di Bitrix24.
  • quando ci si connette ai portali con l’opzione “Proprio dominio” attivata.
  • quando si effettuano le richieste API/REST dal proprio server a Bitrix24.

È dovuto al fatto che il certificato DST Root CA X3 è scaduto, ma fa parte della catena dei certificati client di Let’s Encrypt emessi da noi e verrà mantenuto fino al 2024 per supportare i dispositivi Android con le versioni 2.3.6-7.1.1.


Come risolvere?

Si consiglia di aggiornare il software e il browser all’ultima versione.

Se utilizzi la macchina virtuale VMBitrix sul tuo server, occorre aggiornare il pacchetto ca-certificates utilizzando il comando:

yum update -y ca-certificates

Se utilizzi un altro ambiente server, contatta l’amministratore di sistema del tuo server.


Connessione ai siti e portali

Il problema non riguarda:

  • Windows >= XP SP3 (con aggiornamento automatico)
  • macOS >= 10.12.1
  • iOS >= 10
  • Android >= 7.1.1
  • Mozilla Firefox >= 50.0
  • Ubuntu >= xenial / 16.04 (con aggiornamenti)
  • Debian >= jessie / 8 (con aggiornamenti)
  • Java 8 >= 8u141
  • Java 7 >= 7u151

Il funzionamento dei browser Chrome, Safari, Edge, Opera, Vivaldi dipende dalla versione del software utilizzato.

In tutti gli altri casi si possono verificare dei problemi di connessione. Potrebbe apparire un messaggio di errore relativo alla scadenza del certificato quando si accede ai siti, agli negozi di Bitrix24 e ai portali con il proprio dominio.


Richieste REST/API

Il problema riguarda principalmente i clienti durante l’esecuzione di richieste con l’utilizzo di API dai server con software obsoleto che utilizzano:

  • openssl-1.0.1 – completamente incompatibile e non funzionerà senza i propri pacchetti (CentOS 6).
  • openssl-1.0.2 – occorre aggiornare il pacchetto ca-certificates sui server (CentOS 7).
  • openssl-1.1.x – completamente compatibile.

Leggi di più sulla compatibilità del certificato radice DST Root CA X3 con i dispositivi e software nella documentazione di Let's Encrypt.


È stato utile
Grazie :)
Opzionale:
Lascia un feedback sull'articolo
Non è stato utile
Mi dispiace :(
Ti dispiacerebbe dirci perché?
Lascia un feedback sull'articolo
Ho ancora qualche domanda